Lucent Sky AVM 3.8 is the first milestone release as we get ready for the next major update - Lucent Sky AVM 4. At the core of this milestone release is a preview of the third generation of the mitigation engine. Built on Lucent Sky's proprietary mitigation technology, the new mitigation engine is expected to expand the types of vulnerabilities that can be automatically remediated and enhance the accuracy and precision of the remediation, while increasing the performance and memory management when mitigating applications with a large number of vulnerabilities. As a preview, the third generation mitigation engine is available in Lucent Sky AVM 3.8 to participants of the Lucent Sky AVM Preview Program, and can be enabled or disabled per-server, per-application or per-scan. If you haven't joined the Lucent Sky AVM Preview Program, you can learn more about it. In addition to the preview, improvements to the current mitigation engine and new vulnerability vector classifications were also included in Lucent Sky AVM 3.8.

Updates in Lucent Sky AVM 3.8 include:

  • Preview of third generation mitigation engine - The third generation mitigation engine is expected to expand the types of vulnerabilities that can be automatically remediated and enhance the accuracy and precision of the remediation, while increasing the performance and memory management when mitigating applications with a large number of vulnerabilities. To use the third generation mitigation engine, include mitigation,preview in the scan arguments.
  • Improvements on the current mitigation engine - The current mitigation engine also received several enhancements and bug fixes to improve the accuracy and precision of the remediation.
  • New vulnerability vector classification - Some vectors were reclassified to help streamline the user experience. You will notice the new vector classification in the Web UI, IDE plug-ins and CLI. Vectors in previous scans will be automatically remapped to the new classification when you update to Lucent Sky AVM 3.8.
  • Bug fixes

If you are using Lucent Sky AVM Enterprise, Standard or Test Edition (either on-premise or cloud), you can update to Lucent Sky AVM 3.8 immediately. Our support team will reach out to you shortly to schedule an update. If you are using Lucent Sky AVM On-Demand, your server will be updated to Lucent Sky AVM 3.8 in the next few days.